Unusually heavy traffic on the plugin portal
Incident Report for Gradle
Resolved
This incident has been resolved.

We will continue to monitor the system in the coming days.
Posted Feb 01, 2024 - 16:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 01, 2024 - 12:53 UTC
Investigating
We are currently investigating the issue.

Traffic against the plugin portal has increased heavily this week, with a serious uptake in traffic from user agents identifying as Renovate and some specific source IPs having increased traffic from nearly nothing to multiple millions requests an hour.

We have enforced rate limiting for the worst offender.
Posted Feb 01, 2024 - 10:16 UTC
This incident affected: Gradle Plugin portal (plugins.gradle.org) (User Interface, Repository).