Intermittent Plugin Portal Outages
Incident Report for Gradle
Resolved
This incident has been resolved.
Posted Apr 01, 2020 - 20:19 UTC
Monitoring
There was only a single crash in the last 24 hours.

We've deployed a fix to prevent the application from crashing and we're now monitoring for the situation that was causing the crash.
Posted Apr 01, 2020 - 14:08 UTC
Identified
We're still seeing intermittent failures that cause the Plugin Portal application to crash and restart. These outages typically last seconds, but they may be sustained for several minutes if the application restarts multiple times.

The failure is particular hard to catch and diagnose because it occurs in our logging framework. We believe we're seeing an instance of https://jira.qos.ch/browse/LOGBACK-1027. We've deployed a change to the Plugin Portal to capture more information and are working on deploying a workaround.

Thank you for your patience.
Posted Mar 31, 2020 - 16:41 UTC
Investigating
We are currently investigating this issue.
Posted Mar 30, 2020 - 14:23 UTC
This incident affected: Gradle Plugin portal (plugins.gradle.org) (User Interface, Repository).