Sporadic 502 Bad Gateway, 500 Internal Server Error for maven-metadata.xml resources
Incident Report for Gradle
Postmortem

Postmortem can be found at https://blog.gradle.org/plugins-jcenter

Posted Jan 20, 2022 - 09:59 UTC

Resolved
JCenter is now back online, systems are fully operational.
Posted Jan 13, 2022 - 06:35 UTC
Monitoring
We have deployed a second fix that should resolve another set of issues encountered by the JCenter outage.

What will remain broken:
- Dependencies that only exist in JCenter and were not mirrored to one of Gradle’s repository manager. There is no solution for those unfortunately until JCenter comes back up.

We will do a post-mortem and explain our plan to remove that dependency altogether later this week.
Posted Jan 12, 2022 - 21:43 UTC
Update
Issue with resolution of `maven-metadata.xml` for plugins hosted on the Gradle Plugin Portal should be resolved.
However regular library dependencies of plugins will still fail to resolve because of the underlying failure of JCenter.

We are looking at a solution for this as well.
Posted Jan 12, 2022 - 20:44 UTC
Identified
We have a temporary fix being validated in development right now which should resolve a number of issues.

We’ll update here when it is deployed so that we can assess whether or not it is enough to get going for now.
We will work on a more permanent solution after that in the coming days.
Posted Jan 12, 2022 - 19:20 UTC
Update
We are continuing to investigate this issue.
Posted Jan 12, 2022 - 17:02 UTC
Investigating
We are currently investigating this issue.
Posted Jan 12, 2022 - 16:56 UTC
This incident affected: Gradle Plugin portal (plugins.gradle.org) (Repository, Gradle's JCenter redirect).